HomePosts Tagged "git"
Posted in Tech

ROOT LG G6 H872 (up to and including 20g) – From XDA

ROOT LG G6 H872 (up to and including 20g) -LG H872 Root 教程 WARNING DO NOT LET YOUR PHONE REBOOT, OR POWER OFF UNTIL I TELL YOU THAT IS WHAT YOU NEED TO DO. If you do, I am not sure what shape your phone will be in. This should go without saying, but you MUST have your bootloader unlocked ( Click H872 Bootloader Unlock  if you don’t know how to unlock H872 Bootloader). If you don’t, you will probably brick your phone. If you use this on any model G6 besides the H872, you will be stuck in a bootloop, and you will not be able to fix it since you will have wiped out download mode! This is safe if no mistakes are made (typos, missing a step, etc). However, if you do mess up, the risk is high that you lose download mode at best, or brick your phone at worst. If you deviate from this procedure, and think: “I can just skip a step, or I can do this on my own Linux install”. Don’t complain if you brick your phone. PREREQUISITES: You must have a version of laf that has the COPY opcode. Since none of the firmware available for the H872 has the COPY opcode, we have to use the H918 laf partition. Grab the H918 10p KDZ: link to 10p KDZ You need to be on 11g or above. Be aware, once you are on 11g+ you cannot downgrade to any versions prior to 11g due to anti-rollback. You will need a copy of the KDZ that your phone is on. If you are not currently on 11g, upgrade before continuing.To download the KDZ firmware please go to https://lg-firmwares.com/ We are going to flash this using the patched LG UP. There may be one that was patched specifically for the G6 — don’t use it, it has NOT been tested. Grab the one for the V20: LGUP_V20dll_Patched It MUST be installed in: C:Program Files (x86)/LG Electronics/  一定要解压LGUP文件夹到这个目录,否则不能识别!! You can’t just unzip it anywhere and run it, it will not find the model file. You need the H872 Unofficial 3.2.3 TWRP by @Eliminator74. 3.2.3 is included in the repo so that you know that you have the exact version.实际测试中,这个可以不用. You need to grab FWUL (version 2.7 or later) and burn it to a USB stick: link  这个就是FWUL U盘Linux 操作系统,用来下面输入代码安装TWRP的 Even if you have Linux, and you think you can install the dependencies, don’t. I know this works from FWUL. If you are rooting on 20a, you will need a Micro-SD card. Copy the TWRP 3.2.3 image and the latest Magisk zip to the SD card. WARNING: Only applies if rooting while on 20a Minor Encryption-related issues have occurred while testing 20a. If your data partition is encrypted, TWRP will NOT be able to decrypt it. Because of this, you will have to perform a wipe and format of your Data partition. Be sure to backup all data on your device prior to continuing by copying important files to an external SD card or […]